Having beagle on 2006

Not so easy…

  • 2006’s beagle is very old and doesn’t support KDE applications (including kmail)
  • There’s nothing on the Mandriva club (asked pkarlsen)
  • There’s nothing on SoS (strange, I remember they had a package some months ago)
  • rpmfind.net only lists cooker packages
  • backporting beagle from cooker requires a lot of packages coming from Gnome and Evolution which I don’t use
  • compiling beagle from sources requires a recent mono
  • compiling mono from sources works… now how can I make my custom built the system default ? I found no “clean” way to do this
  • backporting mono from cooker doesn’t work on 2006 even if every requirement is met

I’m stuck😦

Update : Arghh… tried to compile “strigi” which is supposed to be lighter… but not for mandriva 2006 user. Recent cmake and CLucene packages required. Even in cooker, CLucene isn’t recent enough for strigi😦 Well, I give up : I’ll wait for Mandriva 2007.

Update : Now I’ve succeeded in installing strigi. It doesn’t do much but does it well, contrary to kat… Improvements I’d like to see : have a bugtracking system, a better frontend, index automatically when the computer is idle. But I guess these features are already planed, the project is in its early stages.

Pas si facile…

  • Le beagle de 2006 est très vieux et ne supporte pas les applications KDE (dont kmail)
  • Il n’y a rien sur le club Mandriva (j’ai demandé à pkarlsen)
  • Il n’y a rien sur SoS (étrange, je me rappelle qu’ils avaient un paquetage il y a quelques mois)
  • rpmfind.net n’affiche que les paquetages cooker
  • backporter beagle à partir de cooker requiert beaucoup de paquetages provenant de Gnome et Evolution que je n’utilise pas
  • compiler beagle à partir des sources requiert un mono récent
  • compiler mono à partir des sources fonctionne… maintenant, comment puis-je faire de ma version maison le défaut du système ? Je n’ai trouvé aucune manière “propre” de le faire
  • backporter mono à partir de cooker ne marche pas sur 2006, même si toutes les dépendances sont remplies

Je suis bloqué😦

Mise à jour : Arghh… j’ai essayé de compiler “strigi” qui est supposé être plus léger… oui mais pas pour les utilisateurs de Mandriva Linux 2006. Des paquetages récents de cmake et CLucene sont requis. Même dans cooker, CLucene n’est pas assez récent pour strigi😦 Bon, j’abandonne : j’attendrais Mandriva 2007.

Mise à jour : Maintenant, j’ai réussi à installer strigi. Il ne fait pas grand chose, mais il le fait bien, au contraire du feu kat… Améliorations que j’aimerais voir : avoir un système de suivi de bugs, une meilleure interface, indexer automatiquement quand l’ordinateur est au repos. Mais je suppose que ces fonctionalités sont déjà prévues, le projet étant à ses débuts.

3 Responses to “Having beagle on 2006”

  1. pepz Says:

    i tried to compile strigi on my mandriva 2007, but the cmake process asks me to set some variables and i don’t know what these variables are…
    can you explain me how to compile strigi?
    have you used SVN?
    thanks bye
    pepz

  2. yoho Says:

    Unfortunately, it’s been a while since I installed strigi and it was on Mdv 2006, so this article is probably not up-to-date anymore. But I’m interested in compiling strigi on mdv2007. Once I’ve given it a try, I’ll post the results here and keep you informed.

  3. pepz Says:

    ok, thank you
    bye
    pepz


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: